No Uber app for Java phones?

by Sylvia N.
(Russell, Kansas)

I have a Tracfone with a browser (LG 530g), but I can't get a uber driver, because I do not have access to a app, what do I do!

--------------
Hi Sylvia,

Unfortunately, I don't think a java version of the app is available. In order to book a cab through Uber you have to have a smartphone - either an iPhone, Android or Windows smartphone.

Android phones are pretty inexpensive these days (and also available from TF and Net10). If you decide to get one, make sure it's somewhat recent as the app requires Android version 4.0.3 or higher.

For those who want to drive for Uber, I believe the same requirement applies, although it might be possible to get the smartphone from Uber itself in that case. You'll want to get a plan that allows for enough or (preferably) unlimited data such as Straight Talk.

Regards,
sb

Click here to post comments

Return to Tracfone Net10 Apps.

Back to the Top of the Page